Cannot turn off Smart Dashes on Mac

Cannot turn off Smart Dashes on Mac

Postby jbeidler » Wed May 03, 2023 10:59 am

Hello,

I am using Flashcards Deluxe 4.53 on macOS 13.3.1, and for the most part it works great. The one issue I am having is that I can disable Smart Dashes under Edit > Substitutions, but it turns back on as soon as I go to the next card.

I went to System Settings > Keyboard > Input Sources and turned off the option to "Use smart quotes and dashes," then restarted my MacBook, but that didn't help.

I think this issue may be specific to Flashcards Deluxe since I checked a couple other apps (TextEdit, Pages, iA Writer) and they show Smart Dashes turned off.

Any help would be appreciated.
jbeidler
 
Posts: 4
Joined: Thu Nov 20, 2014 4:29 pm

Re: Cannot turn off Smart Dashes on Mac

Postby Ernie » Wed May 03, 2023 3:32 pm

I don't know why the system setting doesn't seem to affect the app. I assume it should.
I don't have an immediate fix.

What I'm planning on doing is that if you turn off "Auto Correct" in the app (you can tap the gear icon at bottom-right of side text entry screen to see this option), it will also turn off the smart dash. On a mac, I don't even know if this "Auto Correct" option does anything, so it seems that you could then turn this off on your mac, and then get your desired behavior.

Hopefully this would work for you.

I don't know when I will release a new version though. I might be 1-2 months.

The system setting "use smart quotes and dashes" doesn't do anything for me that I can see. It will still substitute in TextEdit.
Yes, you can use the shortcut menu to change this behavior, but in Flashcards Deluxe, each side is a NEW text edit control, so the system doesn't seem to remember. I don't think I have any way to deal with this, as I assume it's baked into MacOS (the shortcut menu behavior). Making all my text edit controls be reused is too much to change.

Ernie
Ernie
Site Admin
 
Posts: 5022
Joined: Fri Oct 01, 2010 6:12 pm
Location: San Francisco / Taiwan

Re: Cannot turn off Smart Dashes on Mac

Postby jbeidler » Wed May 03, 2023 5:51 pm

Hi Ernie,

Thank you for the quick response, and for all your work on this great app. For the time being, I am working around this issue by including both "--" and "—" as correct answers.

Joshua
jbeidler
 
Posts: 4
Joined: Thu Nov 20, 2014 4:29 pm

Return to Comments, Questions and Feedback